summaryrefslogtreecommitdiff
path: root/boot/u-boot/u-boot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/u-boot/u-boot.mk')
-rw-r--r--boot/u-boot/u-boot.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index f97674ada..971920751 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -193,9 +193,11 @@ u-boot-configured: $(U_BOOT_DIR)/.header_modified
ifeq ($(BR2_TARGET_UBOOT),y)
TARGETS+=u-boot
-# we NEED a board name
+# we NEED a board name unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(U_BOOT_BOARD_NAME),)
$(error NO U-Boot board name set. Check your BR2_TARGET_UBOOT_BOARDNAME setting)
endif
+endif
endif