summaryrefslogtreecommitdiff
path: root/boot/uboot/uboot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/uboot/uboot.mk')
-rw-r--r--boot/uboot/uboot.mk19
1 files changed, 0 insertions, 19 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 0610e4c9d..142557995 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -78,35 +78,16 @@ define UBOOT_CONFIGURE_CMDS
@echo "#endif /* __BR2_ADDED_CONFIG_H */" >> $(@D)/include/config.h
endef
-ifeq ($(BR2_TARGET_UBOOT_TOOL_ENV),y)
-define UBOOT_BUILD_TARGET_ENV_UTILS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) HOSTCC="$(TARGET_CC)" -C $(@D) env
-endef
-endif
-
define UBOOT_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(UBOOT_CONFIGURE_OPTS) \
$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
$(UBOOT_MAKE_TARGET)
- $(UBOOT_BUILD_TARGET_ENV_UTILS)
endef
define UBOOT_INSTALL_IMAGES_CMDS
cp -dpf $(@D)/$(UBOOT_BIN) $(BINARIES_DIR)/
endef
-ifeq ($(BR2_TARGET_UBOOT_TOOL_ENV),y)
-define UBOOT_INSTALL_TARGET_ENV_UTILS
- $(INSTALL) -m 0755 -D $(@D)/tools/env/fw_printenv \
- $(TARGET_DIR)/usr/sbin/fw_printenv
- ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
-endef
-endif
-
-define UBOOT_INSTALL_TARGET_CMDS
- $(UBOOT_INSTALL_TARGET_ENV_UTILS)
-endef
-
$(eval $(call GENTARGETS,boot,uboot))
ifeq ($(BR2_TARGET_UBOOT),y)