summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
Diffstat (limited to 'boot')
-rw-r--r--boot/u-boot/Config.in6
-rw-r--r--boot/u-boot/u-boot.mk2
2 files changed, 6 insertions, 2 deletions
diff --git a/boot/u-boot/Config.in b/boot/u-boot/Config.in
index 3ba1ef3a9..00a4a5f24 100644
--- a/boot/u-boot/Config.in
+++ b/boot/u-boot/Config.in
@@ -12,10 +12,13 @@ config BR2_TARGET_UBOOT_BOARDNAME
choice
prompt "U-Boot Version"
- default BR2_TARGET_UBOOT_2010_12
+ default BR2_TARGET_UBOOT_2011_03
help
Select the specific U-Boot version you want to use
+config BR2_TARGET_UBOOT_2011_03
+ bool "2011.03"
+
config BR2_TARGET_UBOOT_2010_12
bool "2010.12"
@@ -42,6 +45,7 @@ endif
config BR2_TARGET_UBOOT_VERSION
string
+ default "2011.03" if BR2_TARGET_UBOOT_2011_03
default "2010.12" if BR2_TARGET_UBOOT_2010_12
default "2010.09" if BR2_TARGET_UBOOT_2010_09
default "2010.06" if BR2_TARGET_UBOOT_2010_06
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index ff3f65e96..047f2c87e 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -11,7 +11,7 @@ U_BOOT_BOARD_NAME:=$(call qstrip,$(BR2_TARGET_UBOOT_BOARDNAME))
# pick some random stable U-Boot version that will be used just to
# build mkimage.
ifeq ($(U_BOOT_VERSION),)
-U_BOOT_VERSION=2010.12
+U_BOOT_VERSION=2011.03
endif
ifeq ($(U_BOOT_VERSION),custom)