summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index cc94eb4ef..a3248c165 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -32,7 +32,7 @@ ROOTFS_DEVICE_TABLE = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE))
define ROOTFS_TARGET_INTERNAL
-$(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
+$(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot host-makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
@$(call MESSAGE,"Generating root filesystem image rootfs.$(1)")
$(foreach hook,$(ROOTFS_$(2)_PRE_GEN_HOOKS),$(call $(hook))$(sep))
rm -f $(FAKEROOT_SCRIPT)