summaryrefslogtreecommitdiff
path: root/fs/cramfs/cramfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/cramfs/cramfs.mk')
-rw-r--r--fs/cramfs/cramfs.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/fs/cramfs/cramfs.mk b/fs/cramfs/cramfs.mk
new file mode 100644
index 000000000..ccd316f5d
--- /dev/null
+++ b/fs/cramfs/cramfs.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# Build the cramfs root filesystem image
+#
+#############################################################
+ifeq ($(BR2_ENDIAN),"BIG")
+CRAMFS_OPTS=-b
+else
+CRAMFS_OPTS=-l
+endif
+
+ifneq ($(TARGET_DEVICE_TABLE),)
+CRAMFS_OPTS += -D $(TARGET_DEVICE_TABLE)
+endif
+
+define ROOTFS_CRAMFS_CMD
+ $(HOST_DIR)/usr/bin/mkcramfs -q $(CRAMFS_OPTS) $(TARGET_DIR) $$@
+endef
+
+ROOTFS_CRAMFS_DEPENDENCIES = host-cramfs
+
+$(eval $(call ROOTFS_TARGET,cramfs)) \ No newline at end of file