summaryrefslogtreecommitdiff
path: root/fs/cramfs
diff options
context:
space:
mode:
Diffstat (limited to 'fs/cramfs')
-rw-r--r--fs/cramfs/Config.in6
-rw-r--r--fs/cramfs/cramfs.mk22
2 files changed, 28 insertions, 0 deletions
diff --git a/fs/cramfs/Config.in b/fs/cramfs/Config.in
new file mode 100644
index 000000000..1a4e32647
--- /dev/null
+++ b/fs/cramfs/Config.in
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_CRAMFS
+ bool "cramfs root filesystem"
+ help
+ Build a cramfs root filesystem
+
+ http://sourceforge.net/projects/cramfs/
diff --git a/fs/cramfs/cramfs.mk b/fs/cramfs/cramfs.mk
new file mode 100644
index 000000000..ccd316f5d
--- /dev/null
+++ b/fs/cramfs/cramfs.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# Build the cramfs root filesystem image
+#
+#############################################################
+ifeq ($(BR2_ENDIAN),"BIG")
+CRAMFS_OPTS=-b
+else
+CRAMFS_OPTS=-l
+endif
+
+ifneq ($(TARGET_DEVICE_TABLE),)
+CRAMFS_OPTS += -D $(TARGET_DEVICE_TABLE)
+endif
+
+define ROOTFS_CRAMFS_CMD
+ $(HOST_DIR)/usr/bin/mkcramfs -q $(CRAMFS_OPTS) $(TARGET_DIR) $$@
+endef
+
+ROOTFS_CRAMFS_DEPENDENCIES = host-cramfs
+
+$(eval $(call ROOTFS_TARGET,cramfs)) \ No newline at end of file