summaryrefslogtreecommitdiff
path: root/fs/squashfs/squashfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/squashfs/squashfs.mk')
-rw-r--r--fs/squashfs/squashfs.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index d72388ebf..f11ba2090 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -4,7 +4,11 @@
#
#############################################################
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+else
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
+endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend