summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/jffs2/Config.in4
-rw-r--r--fs/skeleton/root/.bashrc48
-rw-r--r--fs/squashfs/Config.in20
-rw-r--r--fs/squashfs/squashfs.mk14
4 files changed, 35 insertions, 51 deletions
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index de1376881..edb1f4d94 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -81,7 +81,9 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
the pagesize is not a power of 2
config BR2_JFFS2_TARGET_SREC
- bool "RootFS in SREC file formet"
+ bool "RootFS in SREC file format"
+ help
+ The binary data will be encoded in Motorola's S-record format
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
diff --git a/fs/skeleton/root/.bashrc b/fs/skeleton/root/.bashrc
deleted file mode 100644
index d13c8f902..000000000
--- a/fs/skeleton/root/.bashrc
+++ /dev/null
@@ -1,48 +0,0 @@
-# ~/.bashrc: executed by bash(1) for non-login interactive shells.
-
-export PATH=\
-/bin:\
-/sbin:\
-/usr/bin:\
-/usr/sbin:\
-/usr/bin/X11:\
-/usr/local/bin
-
-# If running interactively, then:
-if [ "$PS1" ]; then
-
- if [ "$BASH" ]; then
- export PS1="[\u@\h \W]\\$ "
- else
- if [ "`id -u`" -eq 0 ]; then
- export PS1='# '
- else
- export PS1='$ '
- fi
- fi
-
- export USER=`id -un`
- export LOGNAME=$USER
- export HOSTNAME=`/bin/hostname`
- export HISTSIZE=1000
- export HISTFILESIZE=1000
- export PAGER='/bin/more '
- export EDITOR='/bin/vi'
- export INPUTRC=/etc/inputrc
- export DMALLOC_OPTIONS=debug=0x34f47d83,inter=100,log=logfile
- export LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.png=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:';
-
- ### Some aliases
- alias ps2='ps facux '
- alias ps1='ps faxo "%U %t %p %a" '
- alias af='ps af'
- alias cls='clear'
- alias ll='/bin/ls --color=tty -laFh'
- alias ls='/bin/ls --color=tty -F'
- alias df='df -h'
- alias indent='indent -bad -bap -bbo -nbc -br -brs -c33 -cd33 -ncdb -ce -ci4 -cli0 -cp33 -cs -d0 -di1 -nfc1 -nfca -hnl -i4 -ip0 -l75 -lp -npcs -npsl -nsc -nsob -nss -ts4 '
- #alias bc='bc -l'
- alias minicom='minicom -c on'
- alias calc='calc -Cd '
- alias bc='calc -Cd '
-fi;
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index bcc93b925..85416becb 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -19,5 +19,23 @@ config BR2_TARGET_ROOTFS_SQUASHFS3
bool "3.x"
endchoice
-endif
+choice
+ prompt "Compression algorithm"
+ default BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
+ depends on BR2_TARGET_ROOTFS_SQUASHFS4
+ help
+ Select the squashfs compression algorithm to use when
+ generating the filesystem.
+
+config BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
+ bool "gzip"
+
+config BR2_TARGET_ROOTFS_SQUASHFS4_LZMA
+ bool "lzma"
+
+config BR2_TARGET_ROOTFS_SQUASHFS4_LZO
+ bool "lzo"
+
+endchoice
+endif
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 6117de62a..7efe979e8 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -6,6 +6,17 @@
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzo
+else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZMA),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzma
+else
+ROOTFS_SQUASHFS_ARGS += -comp gzip
+endif
+endif
+
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
@@ -19,7 +30,8 @@ endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))