summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index a3e5a0c02..3fc259c22 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -160,3 +160,16 @@ linux26-rebuild-with-initramfs: $(LINUX26_DIR)/.stamp_initramfs_rebuilt
ifeq ($(BR2_LINUX_KERNEL),y)
TARGETS+=linux26
endif
+
+# Checks to give errors that the user can understand
+ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
+$(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
+endif
+endif
+
+ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)),)
+$(error No kernel configuration file specified, check your BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE setting)
+endif
+endif \ No newline at end of file