summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk14
1 files changed, 0 insertions, 14 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ca216a3e3..1b7e0b755 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -119,18 +119,6 @@ endef
LINUX_POST_PATCH_HOOKS += LINUX_APPLY_PATCHES
-ifeq ($(KERNEL_ARCH),microblaze)
-# on microblaze, we always want mkimage
-LINUX_DEPENDENCIES+=host-uboot-tools
-
-define LINUX_COPY_DTS
- if test -f "$(BR2_LINUX_KERNEL_DTS_FILE)" ; then \
- cp $(BR2_LINUX_KERNEL_DTS_FILE) $(@D)/arch/microblaze/boot/dts ; \
- else \
- echo "Cannot copy dts file!" ; \
- fi
-endef
-endif
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
KERNEL_SOURCE_CONFIG = $(KERNEL_ARCH_PATH)/configs/$(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
@@ -145,8 +133,6 @@ define LINUX_CONFIGURE_CMDS
$(if $(BR2_ARM_EABI),
$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config),
$(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config))
- $(if $(BR2_microblaze),
- $(call LINUX_COPY_DTS))
# As the kernel gets compiled before root filesystems are
# built, we create a fake cpio file. It'll be
# replaced later by the real cpio archive, and the kernel will be