summaryrefslogtreecommitdiff
path: root/make/bash.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/bash.mk')
-rw-r--r--make/bash.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/make/bash.mk b/make/bash.mk
index 23370612a..21a31d060 100644
--- a/make/bash.mk
+++ b/make/bash.mk
@@ -17,6 +17,9 @@ bash-source: $(DL_DIR)/$(BASH_SOURCE)
$(BASH_DIR)/.unpacked: $(DL_DIR)/$(BASH_SOURCE)
$(BASH_CAT) $(DL_DIR)/$(BASH_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ # This is broken when -lintl is added to LIBS
+ perl -i -p -e 's,LIBS_FOR_BUILD =.*,LIBS_FOR_BUILD =,g' \
+ $(BASH_DIR)/builtins/Makefile.in
touch $(BASH_DIR)/.unpacked
$(BASH_DIR)/.configured: $(BASH_DIR)/.unpacked
@@ -38,7 +41,7 @@ $(BASH_DIR)/.configured: $(BASH_DIR)/.unpacked
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
- --disable-nls \
+ $(DISABLE_NLS) \
--with-curses \
--enable-alias \
);