summaryrefslogtreecommitdiff
path: root/make/patch.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/patch.mk')
-rw-r--r--make/patch.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/patch.mk b/make/patch.mk
index 4f7329f6b..e8ceec1ad 100644
--- a/make/patch.mk
+++ b/make/patch.mk
@@ -21,9 +21,11 @@ $(GNUPATCH_DIR)/.unpacked: $(DL_DIR)/$(GNUPATCH_SOURCE)
$(GNUPATCH_DIR)/.configured: $(GNUPATCH_DIR)/.unpacked
(cd $(GNUPATCH_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \