summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 4cd63a36e..3f523dc5e 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -294,15 +294,13 @@ endef
################################################################################
# AUTOTARGETS -- the target generator macro for autotools packages
#
-# Argument 1 is the package directory prefix [mandatory]
-# Argument 2 is the lowercase package name [mandatory]
-# Argument 3 is "target" or "host" [optional, default: "target"]
+# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
define AUTOTARGETS
-ifeq ($(3),host)
-$(call AUTOTARGETS_INNER,$(3)-$(2),$(call UPPERCASE,$(3)-$(2)),$(call UPPERCASE,$(2)),$(1),host)
+ifeq ($(1),host)
+$(call AUTOTARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
else
-$(call AUTOTARGETS_INNER,$(2),$(call UPPERCASE,$(2)),$(call UPPERCASE,$(2)),$(1),target)
+$(call AUTOTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
endif
endef