summaryrefslogtreecommitdiff
path: root/package/cloop/cloop-2.634-1-cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/cloop/cloop-2.634-1-cflags.patch')
-rw-r--r--package/cloop/cloop-2.634-1-cflags.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/cloop/cloop-2.634-1-cflags.patch b/package/cloop/cloop-2.634-1-cflags.patch
new file mode 100644
index 000000000..c421dd7f8
--- /dev/null
+++ b/package/cloop/cloop-2.634-1-cflags.patch
@@ -0,0 +1,30 @@
+Take into account the CFLAGS/LDFLAGS passed in the environment.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: host-cloop-2.634-1/Makefile
+===================================================================
+--- host-cloop-2.634-1.orig/Makefile 2010-12-16 09:17:52.826555645 +0100
++++ host-cloop-2.634-1/Makefile 2010-12-16 09:18:57.208713338 +0100
+@@ -15,7 +15,7 @@
+ endif
+
+ ifdef APPSONLY
+-CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
++CLOOP_CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
+ endif
+
+ KERNOBJ:=compressed_loop.o
+@@ -53,10 +53,10 @@
+ ( cd advancecomp-1.15 ; ./configure && $(MAKE) advfs )
+
+ extract_compressed_fs: extract_compressed_fs.c
+- $(CC) -Wall -O2 -s -o $@ $< -lz
++ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -Wall -O2 -s -o $@ $< -lz
+
+ cloop_suspend: cloop_suspend.o
+- $(CC) -o $@ $<
++ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -o $@ $<
+
+ clean:
+ rm -rf create_compressed_fs extract_compressed_fs zoom *.o *.ko Module.symvers .cloop* .compressed_loop.* .tmp*