summaryrefslogtreecommitdiff
path: root/package/games/vice
diff options
context:
space:
mode:
Diffstat (limited to 'package/games/vice')
-rw-r--r--package/games/vice/Config.in6
-rw-r--r--package/games/vice/vice-1.22-remove-bzero.patch20
-rw-r--r--package/games/vice/vice.mk17
3 files changed, 43 insertions, 0 deletions
diff --git a/package/games/vice/Config.in b/package/games/vice/Config.in
new file mode 100644
index 000000000..48967e466
--- /dev/null
+++ b/package/games/vice/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_VICE
+ bool "vice"
+ help
+ VICE is a Commodore emulator
+
+ http://www.viceteam.org/online
diff --git a/package/games/vice/vice-1.22-remove-bzero.patch b/package/games/vice/vice-1.22-remove-bzero.patch
new file mode 100644
index 000000000..5836a9fce
--- /dev/null
+++ b/package/games/vice/vice-1.22-remove-bzero.patch
@@ -0,0 +1,20 @@
+--- a/src/network.c 2007-07-15 18:49:24.000000000 -0400
++++ b/src/network.c 2008-03-01 21:29:40.000000000 -0500
+@@ -742,7 +742,7 @@ int network_start_server(void)
+
+ #ifdef HAVE_IPV6
+ if (netplay_ipv6) {
+- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
++ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
+ server_addr6.sin6_port = htons(server_port);
+ server_addr6.sin6_family = PF_INET6;
+ server_addr6.sin6_addr=in6addr_any;
+@@ -853,7 +853,7 @@ int network_connect_client(void)
+ }
+ #ifdef HAVE_IPV6
+ if (netplay_ipv6) {
+- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
++ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
+ server_addr6.sin6_port = htons(server_port);
+ server_addr6.sin6_family = PF_INET6;
+ memcpy(&server_addr6.sin6_addr, server_hostent->h_addr, server_hostent->h_length);
diff --git a/package/games/vice/vice.mk b/package/games/vice/vice.mk
new file mode 100644
index 000000000..e59c6bfa1
--- /dev/null
+++ b/package/games/vice/vice.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# vice
+#
+#############################################################
+VICE_VERSION = 1.22
+VICE_SOURCE = vice-$(VICE_VERSION).tar.gz
+VICE_SITE = http://www.viceteam.org/online
+VICE_INSTALL_STAGING = NO
+VICE_INSTALL_TARGET = YES
+
+VICE_CONF_OPT = --without-resid --with-alsa CFLAGS="-O0"
+
+VICE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,vice))
+