summaryrefslogtreecommitdiff
path: root/package/grep/grep.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/grep/grep.mk')
-rw-r--r--package/grep/grep.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index c12b1df1c..0e99698e0 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -11,6 +11,10 @@ GNUGREP_CAT:=$(ZCAT)
GNUGREP_BINARY:=src/grep
GNUGREP_TARGET_BINARY:=bin/grep
+ifeq ($(BR2_ENABLE_LOCALE),y)
+GNUGREP_EXTRA_DEPS:=gettext libintl
+endif
+
$(DL_DIR)/$(GNUGREP_SOURCE):
$(WGET) -P $(DL_DIR) $(GNUGREP_SITE)/$(GNUGREP_SOURCE)
@@ -65,7 +69,7 @@ grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
$(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
-grep: uclibc gettext libintl grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
grep-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall