summaryrefslogtreecommitdiff
path: root/package/iptables/iptables.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/iptables/iptables.mk')
-rw-r--r--package/iptables/iptables.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index fbb5f18ce..93f2c32be 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -3,7 +3,7 @@
# iptables
#
#############################################################
-IPTABLES_VERSION = 1.4.1
+IPTABLES_VERSION = 1.4.2
IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
@@ -16,3 +16,10 @@ IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
IPTABLES_MAKE_OPT = GLIB_GENMARSHAL=$(HOST_GLIB)/bin/glib-genmarshal GLIB_MKENUMS=$(HOST_GLIB)/bin/glib-mkenums
$(eval $(call AUTOTARGETS,package,iptables))
+
+$(IPTABLES_TARGET_UNINSTALL):
+ $(call MESSAGE,"Uninstalling")
+ rm -f $(TARGET_DIR)/usr/bin/iptables-xml
+ rm -f $(TARGET_DIR)/usr/sbin/iptables* $(TARGET_DIR)/usr/sbin/ip6tables*
+ rm -rf $(TARGET_DIR)/usr/lib/xtables
+ rm -f $(IPTABLES_TARGET_INSTALL_TARGET)