summaryrefslogtreecommitdiff
path: root/package/jquery-sparkline
diff options
context:
space:
mode:
Diffstat (limited to 'package/jquery-sparkline')
-rw-r--r--package/jquery-sparkline/Config.in13
-rw-r--r--package/jquery-sparkline/jquery-sparkline.mk18
2 files changed, 31 insertions, 0 deletions
diff --git a/package/jquery-sparkline/Config.in b/package/jquery-sparkline/Config.in
new file mode 100644
index 000000000..ae66364aa
--- /dev/null
+++ b/package/jquery-sparkline/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_JQUERY_SPARKLINE
+ bool "jQuery-Sparkline"
+ select BR2_PACKAGE_JQUERY
+ help
+ This jQuery plugin generates sparklines (small inline
+ charts) directly in the browser using data supplied either
+ inline in the HTML, or via javascript.
+
+ The plugin is compatible with most modern browsers and has
+ been tested with Firefox 2+, Safari 3+, Opera 9, Google
+ Chrome and Internet Explorer 6, 7 & 8.
+
+ http://www.omnipotent.net/jquery.sparkline/
diff --git a/package/jquery-sparkline/jquery-sparkline.mk b/package/jquery-sparkline/jquery-sparkline.mk
new file mode 100644
index 000000000..93dddf094
--- /dev/null
+++ b/package/jquery-sparkline/jquery-sparkline.mk
@@ -0,0 +1,18 @@
+JQUERY_SPARKLINE_VERSION = 1.6
+JQUERY_SPARKLINE_SITE = http://www.omnipotent.net/jquery.sparkline/$(JQUERY_SPARKLINE_VERSION)
+JQUERY_SPARKLINE_SOURCE = jquery.sparkline.min.js
+
+define JQUERY_SPARKLINE_EXTRACT_CMDS
+ cp $(DL_DIR)/$(JQUERY_SPARKLINE_SOURCE) $(@D)
+endef
+
+define JQUERY_SPARKLINE_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/$(JQUERY_SPARKLINE_SOURCE) \
+ $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+define JQUERY_SPARKLINE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+$(eval $(call GENTARGETS))