summaryrefslogtreecommitdiff
path: root/package/libtorrent/libtorrent.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libtorrent/libtorrent.mk')
-rw-r--r--package/libtorrent/libtorrent.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/libtorrent/libtorrent.mk b/package/libtorrent/libtorrent.mk
new file mode 100644
index 000000000..100e68465
--- /dev/null
+++ b/package/libtorrent/libtorrent.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libtorrent
+#
+#############################################################
+
+LIBTORRENT_VERSION = 0.13.2
+LIBTORRENT_SITE = http://libtorrent.rakshasa.no/downloads
+LIBTORRENT_DEPENDENCIES = host-pkg-config libsigc \
+ $(if $(BR2_PACKAGE_OPENSSL),openssl)
+LIBTORRENT_CONF_OPT = --enable-aligned \
+ $(if $(BR2_PACKAGE_OPENSSL),--enable-openssl,--disable-openssl)
+LIBTORRENT_INSTALL_STAGING = YES
+LIBTORRENT_AUTORECONF = YES
+
+$(eval $(call AUTOTARGETS))