summaryrefslogtreecommitdiff
path: root/package/libxml2/libxml2.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml2/libxml2.mk')
-rw-r--r--package/libxml2/libxml2.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 2a267b2f9..8f2878d65 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -12,10 +12,7 @@ ifneq ($(BR2_LARGEFILE),y)
LIBXML2_CONF_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
endif
-LIBXML2_CONF_OPT = --with-gnu-ld --enable-shared \
- --enable-static \
- --without-debugging --without-python \
- --without-threads
+LIBXML2_CONF_OPT = --with-gnu-ld --without-python --without-debug
define LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
$(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
@@ -26,9 +23,7 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
HOST_LIBXML2_DEPENDENCIES = host-pkg-config
-HOST_LIBXML2_CONF_OPT = \
- --enable-shared --without-debugging --without-python \
- --without-threads
+HOST_LIBXML2_CONF_OPT = --without-debug --without-python
define LIBXML2_REMOVE_CONFIG_SCRIPTS
$(RM) -f $(TARGET_DIR)/usr/bin/xml2-config