summaryrefslogtreecommitdiff
path: root/package/minicom/minicom.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/minicom/minicom.mk')
-rw-r--r--package/minicom/minicom.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/minicom/minicom.mk b/package/minicom/minicom.mk
new file mode 100644
index 000000000..cb09b839f
--- /dev/null
+++ b/package/minicom/minicom.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# minicom
+#
+#############################################################
+MINICOM_VERSION = 2.6
+MINICOM_SOURCE = minicom-$(MINICOM_VERSION).tar.gz
+MINICOM_SITE = http://alioth.debian.org/frs/download.php/3689/
+
+# pkg-config is only used to check for liblockdev, which we don't have
+# in BR, so instead of adding host-pkg-config as a dependency, simply
+# make sure the host version isn't used so we don't end up with problems
+# if people have liblockdev1-dev installed
+MINICOM_CONF_ENV = PKG_CONFIG=/bin/false
+
+MINICOM_DEPENDENCIES = ncurses $(if $(BR2_ENABLE_LOCALE),,libiconv)
+
+$(eval $(call AUTOTARGETS))