summaryrefslogtreecommitdiff
path: root/package/multimedia/gst-dsp/gst-dsp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/gst-dsp/gst-dsp.mk')
-rw-r--r--package/multimedia/gst-dsp/gst-dsp.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/multimedia/gst-dsp/gst-dsp.mk b/package/multimedia/gst-dsp/gst-dsp.mk
new file mode 100644
index 000000000..f55f5109a
--- /dev/null
+++ b/package/multimedia/gst-dsp/gst-dsp.mk
@@ -0,0 +1,19 @@
+GST_DSP_VERSION=0.8.0
+GST_DSP_SOURCE=gst-dsp-$(GST_DSP_VERSION).tar.gz
+GST_DSP_SITE=http://gst-dsp.googlecode.com/files/
+
+define GST_DSP_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e
+endef
+
+define GST_DSP_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e DESTDIR=$(TARGET_DIR) install
+endef
+
+define GST_DSP_UNINSTALL_TARGET_CMDS
+ $(RM) $(TARGET_DIR)/usr/lib/gstreamer-0.10/libgstdsp.so
+endef
+
+GST_DSP_DEPENDENCIES = gstreamer tidsp-binaries
+
+$(eval $(call GENTARGETS,package/multimedia,gst-dsp))