summaryrefslogtreecommitdiff
path: root/package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/gst-plugins-bad/gst-plugins-bad.mk')
-rw-r--r--package/multimedia/gst-plugins-bad/gst-plugins-bad.mk56
1 files changed, 37 insertions, 19 deletions
diff --git a/package/multimedia/gst-plugins-bad/gst-plugins-bad.mk b/package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
index 20aad76fb..a737befea 100644
--- a/package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
+++ b/package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
@@ -3,7 +3,7 @@
# gst-plugins-bad
#
#############################################################
-GST_PLUGINS_BAD_VERSION = 0.10.22
+GST_PLUGINS_BAD_VERSION = 0.10.23
GST_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST_PLUGINS_BAD_VERSION).tar.bz2
GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
@@ -40,6 +40,12 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-asfmux
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUDIOVISUALIZERS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-audiovisualizers
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-audiovisualizers
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-autoconvert
else
@@ -124,6 +130,12 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-dvdspu
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FACEOVERLAY),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-faceoverlay
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-faceoverlay
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FESTIVAL),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-festival
else
@@ -142,6 +154,12 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-freeze
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEVERB),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-freeverb
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-freeverb
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-frei0r
else
@@ -190,22 +208,16 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-id3tag
endif
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTERLACE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-interlace
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTER),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-inter
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-interlace
+GST_PLUGINS_BAD_CONF_OPT += --disable-inter
endif
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INVTELECINE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-invtelecine
-else
-GST_PLUGINS_BAD_CONF_OPT += --disable-invtelecine
-endif
-
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INVTELECINE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-invtelecine
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTERLACE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-interlace
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-invtelecine
+GST_PLUGINS_BAD_CONF_OPT += --disable-interlace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_IVFPARSE),y)
@@ -274,12 +286,6 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-mpegtsmux
endif
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEG4VIDEOPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpeg4videoparse
-else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpeg4videoparse
-endif
-
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGVIDEOPARSE),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-mpegvideoparse
else
@@ -340,6 +346,12 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-real
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REMOVESILENCE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-removesilence
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-removesilence
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPMUX),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-rtpmux
else
@@ -382,6 +394,12 @@ else
GST_PLUGINS_BAD_CONF_OPT += --disable-siren
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SMOOTH),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-smooth
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-smooth
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SPEED),y)
GST_PLUGINS_BAD_CONF_OPT += --enable-speed
else