summaryrefslogtreecommitdiff
path: root/package/ncftp/ncftp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ncftp/ncftp.mk')
-rw-r--r--package/ncftp/ncftp.mk25
1 files changed, 23 insertions, 2 deletions
diff --git a/package/ncftp/ncftp.mk b/package/ncftp/ncftp.mk
index 1a0ba94b1..911c8cefc 100644
--- a/package/ncftp/ncftp.mk
+++ b/package/ncftp/ncftp.mk
@@ -10,8 +10,29 @@ NCFTP_DIR:=$(BUILD_DIR)/ncftp-$(NCFTP_VERSION)
NCFTP_TARGET_BINS:=ncftp
-ifeq ($(strip $(BR2_PACKAGE_NCFTP_UTILS)),y)
-NCFTP_TARGET_BINS+=ncftpbatch ncftpbookmarks ncftpget ncftpls ncftpput
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_GET)),y)
+NCFTP_TARGET_BINS+=ncftpget
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_PUT)),y)
+NCFTP_TARGET_BINS+=ncftpput
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_LS)),y)
+NCFTP_TARGET_BINS+=ncftpls
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_BATCH)),y)
+NCFTP_TARGET_BINS+=ncftpbatch
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_SPOOLER)),y)
+#Someone needs to figure out what to do...
+NCFTP_TARGET_BINS+=
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_NCFTP_BOOKMARKS)),y)
+NCFTP_TARGET_BINS+=ncftpbookmarks
endif
ncftp-source: $(DL_DIR)/$(NCFTP_SOURCE)