summaryrefslogtreecommitdiff
path: root/package/pkg-cmaketargets.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-cmaketargets.mk')
-rw-r--r--package/pkg-cmaketargets.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/pkg-cmaketargets.mk b/package/pkg-cmaketargets.mk
index b405df505..71cc61036 100644
--- a/package/pkg-cmaketargets.mk
+++ b/package/pkg-cmaketargets.mk
@@ -190,13 +190,8 @@ endef
# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
-define CMAKETARGETS
-ifeq ($(1),host)
-$(call CMAKETARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
-else
-$(call CMAKETARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
-endif
-endef
+CMAKETARGETS = $(call CMAKETARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+host-cmake-package = $(call CMAKETARGETS_INNER,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
################################################################################
# Generation of the CMake toolchain file