summaryrefslogtreecommitdiff
path: root/package/pkg-cmaketargets.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-cmaketargets.mk')
-rw-r--r--package/pkg-cmaketargets.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-cmaketargets.mk b/package/pkg-cmaketargets.mk
index 371ab11c7..b405df505 100644
--- a/package/pkg-cmaketargets.mk
+++ b/package/pkg-cmaketargets.mk
@@ -98,7 +98,7 @@ endif
# This must be repeated from GENTARGETS_INNER, otherwise we only get
# host-cmake in _DEPENDENCIES because of the following line
-$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+$(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
$(2)_DEPENDENCIES += host-cmake