summaryrefslogtreecommitdiff
path: root/package/python/python-2.7-003-no-import-when-cross-compiling.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python-2.7-003-no-import-when-cross-compiling.patch')
-rw-r--r--package/python/python-2.7-003-no-import-when-cross-compiling.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/python/python-2.7-003-no-import-when-cross-compiling.patch b/package/python/python-2.7-003-no-import-when-cross-compiling.patch
new file mode 100644
index 000000000..162ba5031
--- /dev/null
+++ b/package/python/python-2.7-003-no-import-when-cross-compiling.patch
@@ -0,0 +1,26 @@
+Disable import check when cross-compiling
+
+Once Python has compiled an extension (i.e some C code, potentially
+linked to a library), it tries to import it. This cannot work in
+cross-compilation mode, so we just disable this check.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ setup.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+Index: Python-2.7.1/setup.py
+===================================================================
+--- Python-2.7.1.orig/setup.py
++++ Python-2.7.1/setup.py
+@@ -304,6 +304,10 @@
+ self.announce('WARNING: skipping import check for Cygwin-based "%s"'
+ % ext.name)
+ return
++ if os.environ.get('CROSS_COMPILING') == 'yes':
++ self.announce('WARNING: skipping import check for cross compiled "%s"'
++ % ext.name)
++ return
+ ext_filename = os.path.join(
+ self.build_lib,
+ self.get_ext_filename(self.get_ext_fullname(ext.name)))