summaryrefslogtreecommitdiff
path: root/package/rpm/rpm.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/rpm/rpm.mk')
-rw-r--r--package/rpm/rpm.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
new file mode 100644
index 000000000..0230befa4
--- /dev/null
+++ b/package/rpm/rpm.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# rpm
+#
+#############################################################
+RPM_VERSION = 5.0.3
+RPM_SITE = http://rpm5.org/files/rpm/rpm-5.0/
+RPM_AUTORECONF = YES
+
+RPM_DEPENDENCIES = zlib beecrypt neon popt
+
+RPM_CONF_ENV = CFLAGS="-I$(STAGING_DIR)/usr/include/beecrypt -I$(STAGING_DIR)/usr/include/neon" \
+ ac_cv_va_copy=yes
+
+RPM_CONF_OPT = --disable-build-versionscript --disable-rpath \
+ --without-selinux \
+ --without-python --without-perl \
+ --with-zlib=$(STAGING_DIR) \
+ --with-libbeecrypt=$(STAGING_DIR) \
+ --with-popt=$(STAGING_DIR) \
+ $(DISABLE_NLS)
+
+RPM_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) program_transform_name= install
+
+$(eval $(call AUTOTARGETS,package,rpm))