summaryrefslogtreecommitdiff
path: root/package/x11r7/xapp_xcursorgen
diff options
context:
space:
mode:
Diffstat (limited to 'package/x11r7/xapp_xcursorgen')
-rw-r--r--package/x11r7/xapp_xcursorgen/Config.in9
-rw-r--r--package/x11r7/xapp_xcursorgen/xapp_xcursorgen.mk13
2 files changed, 22 insertions, 0 deletions
diff --git a/package/x11r7/xapp_xcursorgen/Config.in b/package/x11r7/xapp_xcursorgen/Config.in
new file mode 100644
index 000000000..f57ac4153
--- /dev/null
+++ b/package/x11r7/xapp_xcursorgen/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_XAPP_XCURSORGEN
+ bool "xcursorgen"
+ default n
+ select BR2_PACKAGE_LIBPNG
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXCURSOR
+ help
+ xcursorgen 1.0.1
+ create an X cursor file from a collection of PNG images
diff --git a/package/x11r7/xapp_xcursorgen/xapp_xcursorgen.mk b/package/x11r7/xapp_xcursorgen/xapp_xcursorgen.mk
new file mode 100644
index 000000000..94d82744d
--- /dev/null
+++ b/package/x11r7/xapp_xcursorgen/xapp_xcursorgen.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# xapp_xcursorgen -- create an X cursor file from a collection of PNG images
+#
+################################################################################
+
+XAPP_XCURSORGEN_VERSION = 1.0.1
+XAPP_XCURSORGEN_SOURCE = xcursorgen-$(XAPP_XCURSORGEN_VERSION).tar.bz2
+XAPP_XCURSORGEN_SITE = http://xorg.freedesktop.org/releases/individual/app
+XAPP_XCURSORGEN_AUTORECONF = YES
+XAPP_XCURSORGEN_DEPENDANCIES = libpng xlib_libX11 xlib_libXcursor
+
+$(eval $(call AUTOTARGETS,xapp_xcursorgen))