summaryrefslogtreecommitdiff
path: root/package/zxing/zxing-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/zxing/zxing-makefile.patch')
-rw-r--r--package/zxing/zxing-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/zxing/zxing-makefile.patch b/package/zxing/zxing-makefile.patch
new file mode 100644
index 000000000..66896bf32
--- /dev/null
+++ b/package/zxing/zxing-makefile.patch
@@ -0,0 +1,30 @@
+[PATCH] add Makefile
+
+The scons based build system doesn't handle cross compilation, special
+compiler flags or (un)installation, so add a simple makefile instead
+which does.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ cpp/core/src/Makefile | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+
+Index: zxing-2.0/cpp/core/src/Makefile
+===================================================================
+--- /dev/null
++++ zxing-2.0/cpp/core/src/Makefile
+@@ -0,0 +1,14 @@
++override CXXFLAGS += -I.
++SRCS := $(shell find -name '*.cpp')
++
++libzxing.a: $(SRCS:.cpp=.o)
++ $(AR) $(ARFLAGS) $@ $^
++
++install: libzxing.a
++ install -D -m 0644 $^ $(DESTDIR)/usr/lib/$^
++ find -name '*.h' -exec install -m 0644 -D "{}" \
++ "$(DESTDIR)/usr/include/{}" ";"
++
++uninstall:
++ rm -f $(DESTDIR)/usr/lib/libzxing.a
++ rm -rf $(DESTDIR)/usr/include/zxing