summaryrefslogtreecommitdiff
path: root/support/scripts/pkg-stats
diff options
context:
space:
mode:
Diffstat (limited to 'support/scripts/pkg-stats')
-rwxr-xr-xsupport/scripts/pkg-stats12
1 files changed, 6 insertions, 6 deletions
diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
index bb1c27d87..8602b0f95 100755
--- a/support/scripts/pkg-stats
+++ b/support/scripts/pkg-stats
@@ -98,27 +98,27 @@ for i in $(find package/ -name '*.mk') ; do
is_manual_target=0
is_manual_host=0
- if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call AUTOTARGETS,host\)" $i > /dev/null ; then
is_auto_host=1
fi
- if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call AUTOTARGETS\)" $i > /dev/null ; then
is_auto_target=1
fi
- if grep -E "\(call GENTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call GENTARGETS,host\)" $i > /dev/null ; then
is_pkg_host=1
fi
- if grep -E "\(call GENTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call GENTARGETS\)" $i > /dev/null ; then
is_pkg_target=1
fi
- if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call CMAKETARGETS,host\)" $i > /dev/null ; then
is_cmake_host=1
fi
- if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call CMAKETARGETS\)" $i > /dev/null ; then
is_cmake_target=1
fi