summaryrefslogtreecommitdiff
path: root/target/cpio
diff options
context:
space:
mode:
Diffstat (limited to 'target/cpio')
-rw-r--r--target/cpio/Config.in9
-rw-r--r--target/cpio/cpioroot.mk11
2 files changed, 20 insertions, 0 deletions
diff --git a/target/cpio/Config.in b/target/cpio/Config.in
index 496a4da0f..3f25cc60b 100644
--- a/target/cpio/Config.in
+++ b/target/cpio/Config.in
@@ -40,3 +40,12 @@ config BR2_TARGET_ROOTFS_CPIO_LZMA
endchoice
+config BR2_TARGET_ROOTFS_CPIO_COPYTO
+ string "also copy the image to..."
+ depends on BR2_TARGET_ROOTFS_CPIO
+ default ""
+ help
+ Copies the resulting image to a secondary location
+ like a tftp server's root directory.
+
+ Example: $(IMAGE)-$(DATE).cpio$(CPIO_ROOTFS_COMPRESSOR_EXT)
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index 3a8d03a0f..c18261e27 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -31,6 +31,9 @@ else
CPIO_TARGET := $(CPIO_BASE)
endif
+ROOTFS_CPIO_COPYTO:=$(strip $(subst ",,$(BR2_TARGET_ROOTFS_CPIO_COPYTO)))
+# "))
+#
cpioroot-init:
rm -f $(TARGET_DIR)/init
@@ -61,10 +64,18 @@ endif
chmod a+x $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
$(STAGING_DIR)/usr/bin/fakeroot -- $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
#-@rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
+ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
+ifneq ($(ROOTFS_CPIO_COPYTO),)
+ $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
+endif
+endif
ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
$(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT): $(CPIO_ROOTFS_COMPRESSOR_PREREQ) $(CPIO_BASE)
$(CPIO_ROOTFS_COMPRESSOR) $(CPIO_BASE) > $(CPIO_TARGET)
+ifneq ($(ROOTFS_CPIO_COPYTO),)
+ $(Q)cp -f $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT) $(ROOTFS_CPIO_COPYTO).$(CPIO_ROOTFS_COMPRESSOR_EXT)
+endif
endif
cpioroot: $(CPIO_TARGET)