summaryrefslogtreecommitdiff
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index ba6450fdb..0ec6f85d2 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -67,9 +67,11 @@ squashfsroot: host-fakeroot makedevs squashfs
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
+ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))
+endif
# Use fakeroot so mksquashfs believes the previous fakery
echo "$(SQUASHFS_DIR)/squashfs-tools/mksquashfs " \
"$(TARGET_DIR) $(SQUASHFS_TARGET) " \