summaryrefslogtreecommitdiff
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk20
1 files changed, 3 insertions, 17 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index 515153a0a..c9eb74327 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -35,24 +35,10 @@ squashfs-dirclean:
# Build the squashfs root filesystem image
#
#############################################################
-SQUASHFS_ENDIANNESS=-le
-ifeq ($(strip $(BR2_armeb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_mips)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
SQUASHFS_ENDIANNESS=-be
+else
+SQUASHFS_ENDIANNESS=-le
endif
SQUASHFS_TARGET:=$(IMAGE).squashfs