summaryrefslogtreecommitdiff
path: root/target/u-boot/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/u-boot/Makefile.in')
-rw-r--r--target/u-boot/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index baf331da7..1386e03a7 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -88,6 +88,9 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot/$(U_BOOT_VERSION) \
u-boot-$(U_BOOT_VERSION)-\*.patch \
u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
+ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),"")
+ toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_ARCH_PATCH_DIR) \*.patch
+endif
ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH)),"")
@mkdir -p $(U_BOOT_PATCH_DIR)
cp -dpr $(BR2_TARGET_UBOOT_CUSTOM_PATCH) $(U_BOOT_PATCH_DIR)