summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index c4962bd3f..f3c7807c7 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -201,7 +201,7 @@ $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.config
fi
touch -c $@
-linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
+linux26-menuconfig: host-sed dirs $(LINUX26_DIR)/.patched
if [ ! -f $(LINUX26_DIR)/.config ]; then \
[ -n "$(LINUX26_KCONFIG)" ] && [ -f $(LINUX26_KCONFIG) ] && \
cp $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config || \
@@ -210,7 +210,7 @@ linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) menuconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured
-linux26-xconfig: $(LINUX26_DIR)/.patched host-sed
+linux26-xconfig: host-sed dirs $(LINUX26_DIR)/.patched
[ -f $(LINUX26_DIR)/.config ] || cp $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) xconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured