summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-3.x.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-3.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 31c5d4b5f..00471d71e 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -335,9 +335,14 @@ endif
ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
-ifeq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
+ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
+ifneq ($(GCC_SNAP_DATE),)
+REAL_GCC_VERSION:=`cat ${GCC_DIR}/gcc/BASE-VER`
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
+else
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
+endif
$(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
PATH=$(TARGET_PATH) \