summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Config.in2
-rw-r--r--toolchain/kernel-headers/Config.in6
-rw-r--r--toolchain/kernel-headers/linux-3.0.32-headers_install-fix-__packed-in-exported-kernel-head.patch (renamed from toolchain/kernel-headers/linux-3.0.31-headers_install-fix-__packed-in-exported-kernel-head.patch)0
-rw-r--r--toolchain/kernel-headers/linux-3.3.7-fix-umode_t.patch (renamed from toolchain/kernel-headers/linux-3.3.5-fix-umode_t.patch)0
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.config-eglibc4
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.config-glibc4
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc4
-rw-r--r--toolchain/toolchain-external/ext-tool.mk9
-rw-r--r--toolchain/uClibc/Config.in2
-rw-r--r--toolchain/uClibc/uClibc-0.9.33.1-mmap64-include-stdint.h-for-uint64_t.patch28
-rw-r--r--toolchain/uClibc/uClibc-0.9.33.1-version.patch23
-rw-r--r--toolchain/uClibc/uClibc-0.9.33.2-define-MSG_CMSG_CLOEXEC.patch (renamed from toolchain/uClibc/uClibc-0.9.33.1-define-MSG_CMSG_CLOEXEC.patch)0
-rw-r--r--toolchain/uClibc/uClibc-0.9.33.2-dup3.patch (renamed from toolchain/uClibc/uClibc-0.9.33.1-dup3.patch)0
13 files changed, 16 insertions, 66 deletions
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index c9c54b88f..fd6956b3a 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -5,7 +5,7 @@ config BR2_PACKAGE_GDB
select BR2_PACKAGE_NCURSES
depends on BR2_USE_WCHAR
depends on BR2_TOOLCHAIN_HAS_THREADS
- depends on !BR2_sh && !BR2_sh64
+ depends on !BR2_sh && !BR2_sh64 && !BR2_avr32
help
Build the full gdb debugger to run on the target.
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index b3fb362d0..17fe7978c 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -64,10 +64,10 @@ config BR2_DEFAULT_KERNEL_HEADERS
default "2.6.37.6" if BR2_KERNEL_HEADERS_2_6_37
default "2.6.38.8" if BR2_KERNEL_HEADERS_2_6_38
default "2.6.39.4" if BR2_KERNEL_HEADERS_2_6_39
- default "3.0.31" if BR2_KERNEL_HEADERS_3_0
+ default "3.0.32" if BR2_KERNEL_HEADERS_3_0
default "3.1.10" if BR2_KERNEL_HEADERS_3_1
- default "3.2.16" if BR2_KERNEL_HEADERS_3_2
- default "3.3.5" if BR2_KERNEL_HEADERS_3_3
+ default "3.2.18" if BR2_KERNEL_HEADERS_3_2
+ default "3.3.7" if BR2_KERNEL_HEADERS_3_3
default "3.4" if BR2_KERNEL_HEADERS_3_4
default "2.6" if BR2_KERNEL_HEADERS_SNAP
default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
diff --git a/toolchain/kernel-headers/linux-3.0.31-headers_install-fix-__packed-in-exported-kernel-head.patch b/toolchain/kernel-headers/linux-3.0.32-headers_install-fix-__packed-in-exported-kernel-head.patch
index 8777b7163..8777b7163 100644
--- a/toolchain/kernel-headers/linux-3.0.31-headers_install-fix-__packed-in-exported-kernel-head.patch
+++ b/toolchain/kernel-headers/linux-3.0.32-headers_install-fix-__packed-in-exported-kernel-head.patch
diff --git a/toolchain/kernel-headers/linux-3.3.5-fix-umode_t.patch b/toolchain/kernel-headers/linux-3.3.7-fix-umode_t.patch
index 966366225..966366225 100644
--- a/toolchain/kernel-headers/linux-3.3.5-fix-umode_t.patch
+++ b/toolchain/kernel-headers/linux-3.3.7-fix-umode_t.patch
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-eglibc b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-eglibc
index cbad52a65..58cdff2d3 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-eglibc
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-eglibc
@@ -294,8 +294,8 @@ CT_CC_LANG_CXX=y
# gcc other options
#
CT_CC_ENABLE_CXX_FLAGS=""
-CT_CC_CORE_EXTRA_CONFIG_ARRAY=""
-CT_CC_EXTRA_CONFIG_ARRAY=""
+CT_CC_CORE_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
+CT_CC_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
CT_CC_STATIC_LIBSTDCXX=y
#
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-glibc b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-glibc
index e57a91dfc..db724ab40 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-glibc
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-glibc
@@ -294,8 +294,8 @@ CT_CC_LANG_CXX=y
# gcc other options
#
CT_CC_ENABLE_CXX_FLAGS=""
-CT_CC_CORE_EXTRA_CONFIG_ARRAY=""
-CT_CC_EXTRA_CONFIG_ARRAY=""
+CT_CC_CORE_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
+CT_CC_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
CT_CC_STATIC_LIBSTDCXX=y
#
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc
index c1150965a..5f1ee7ea8 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc
@@ -293,8 +293,8 @@ CT_CC_LANG_CXX=y
# gcc other options
#
CT_CC_ENABLE_CXX_FLAGS=""
-CT_CC_CORE_EXTRA_CONFIG_ARRAY=""
-CT_CC_EXTRA_CONFIG_ARRAY=""
+CT_CC_CORE_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
+CT_CC_EXTRA_CONFIG_ARRAY="--disable-decimal-float"
CT_CC_STATIC_LIBSTDCXX=y
#
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index b163aeed7..3f58aad3e 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -384,11 +384,12 @@ $(STAMP_DIR)/ext-toolchain-installed: $(STAMP_DIR)/ext-toolchain-checked
ARCH_LIBC_A_LOCATION=`readlink -f $$(LANG=C $(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS) -print-file-name=libc.a)` ; \
ARCH_SYSROOT_DIR=`echo $${ARCH_LIBC_A_LOCATION} | sed -r -e 's:usr/lib(64)?/(.*/)?libc\.a::'` ; \
ARCH_LIB_DIR=`echo $${ARCH_LIBC_A_LOCATION} | sed -r -e 's:.*/usr/(lib(64)?)/(.*/)?libc.a:\1:'` ; \
+ SUPPORT_LIB_DIR="" ; \
if test `find $${ARCH_SYSROOT_DIR} -name 'libstdc++.a' | wc -l` -eq 0 ; then \
- LIBSTDCPP_A_LOCATION=`readlink -f $$(LANG=C $(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS) -print-file-name=libstdc++.a)` ; \
- SUPPORT_LIB_DIR=`echo $${LIBSTDCPP_A_LOCATION} | sed -r -e 's:libstdc\+\+\.a::'` ; \
- else \
- SUPPORT_LIB_DIR="" ; \
+ LIBSTDCPP_A_LOCATION=$$(LANG=C $(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS) -print-file-name=libstdc++.a) ; \
+ if [ -e "$${LIBSTDCPP_A_LOCATION}" ]; then \
+ SUPPORT_LIB_DIR=`readlink -f $${LIBSTDCPP_A_LOCATION} | sed -r -e 's:libstdc\+\+\.a::'` ; \
+ fi ; \
fi ; \
ARCH_SUBDIR=`echo $${ARCH_SYSROOT_DIR} | sed -r -e "s:^$${SYSROOT_DIR}(.*)/$$:\1:"` ; \
mkdir -p $(TARGET_DIR)/lib ; \
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index 160ead417..d8b8a2a0c 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -37,7 +37,7 @@ config BR2_UCLIBC_VERSION_STRING
string
default 0.9.31.1 if BR2_UCLIBC_VERSION_0_9_31
default 0.9.32.1 if BR2_UCLIBC_VERSION_0_9_32
- default 0.9.33.1 if BR2_UCLIBC_VERSION_0_9_33
+ default 0.9.33.2 if BR2_UCLIBC_VERSION_0_9_33
default $BR2_USE_UCLIBC_SNAPSHOT if BR2_UCLIBC_VERSION_SNAPSHOT
config BR2_UCLIBC_CONFIG
diff --git a/toolchain/uClibc/uClibc-0.9.33.1-mmap64-include-stdint.h-for-uint64_t.patch b/toolchain/uClibc/uClibc-0.9.33.1-mmap64-include-stdint.h-for-uint64_t.patch
deleted file mode 100644
index 8b08a2cd8..000000000
--- a/toolchain/uClibc/uClibc-0.9.33.1-mmap64-include-stdint.h-for-uint64_t.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 47009e1e1c6b721c38b5ffa2eeb9202fb8db298a Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 11 Apr 2012 16:01:29 -0400
-Subject: [PATCH 1/2] mmap64: include stdint.h for uint64_t
-
-Some targets include this implicitly, but pull it in explicitly for those
-which don't to fix building for them.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- libc/sysdeps/linux/common/mmap64.c | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/libc/sysdeps/linux/common/mmap64.c b/libc/sysdeps/linux/common/mmap64.c
-index 3c97c84..cebf961 100644
---- a/libc/sysdeps/linux/common/mmap64.c
-+++ b/libc/sysdeps/linux/common/mmap64.c
-@@ -10,6 +10,7 @@
- #ifdef __UCLIBC_HAS_LFS__
-
- #include <errno.h>
-+#include <stdint.h>
- #include <unistd.h>
- #include <sys/mman.h>
- #include <sys/syscall.h>
---
-1.7.3.4
-
diff --git a/toolchain/uClibc/uClibc-0.9.33.1-version.patch b/toolchain/uClibc/uClibc-0.9.33.1-version.patch
deleted file mode 100644
index 37f8565ff..000000000
--- a/toolchain/uClibc/uClibc-0.9.33.1-version.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-[PATCH] fix version number
-
-Somehow the 0.9.33.1 tarball thinks it is 0.9.33.2-git, as pointed out
-by Mike Frysinger.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- Rules.mak | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: uClibc-0.9.33.1/Rules.mak
-===================================================================
---- uClibc-0.9.33.1.orig/Rules.mak
-+++ uClibc-0.9.33.1/Rules.mak
-@@ -105,7 +105,7 @@
- MAJOR_VERSION := 0
- MINOR_VERSION := 9
- SUBLEVEL := 33
--EXTRAVERSION :=.2-git
-+EXTRAVERSION :=.1
- VERSION := $(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL)
- ABI_VERSION := $(MAJOR_VERSION)
- ifneq ($(EXTRAVERSION),)
diff --git a/toolchain/uClibc/uClibc-0.9.33.1-define-MSG_CMSG_CLOEXEC.patch b/toolchain/uClibc/uClibc-0.9.33.2-define-MSG_CMSG_CLOEXEC.patch
index c699b6b11..c699b6b11 100644
--- a/toolchain/uClibc/uClibc-0.9.33.1-define-MSG_CMSG_CLOEXEC.patch
+++ b/toolchain/uClibc/uClibc-0.9.33.2-define-MSG_CMSG_CLOEXEC.patch
diff --git a/toolchain/uClibc/uClibc-0.9.33.1-dup3.patch b/toolchain/uClibc/uClibc-0.9.33.2-dup3.patch
index 66b419e2b..66b419e2b 100644
--- a/toolchain/uClibc/uClibc-0.9.33.1-dup3.patch
+++ b/toolchain/uClibc/uClibc-0.9.33.2-dup3.patch