summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2007-12-12 08:48:30 -0800
committerDan Nicholson <dbn.lists@gmail.com>2007-12-12 08:48:30 -0800
commit41b00707e20f0c07e0dce055884c773de4b82612 (patch)
treed9d6134abbefcb10c5adc5056d7edb6198cdb46c /configure.ac
parentaab38cfc43581e0d09195c2e53092d355a09841c (diff)
autoconf: More informative errors when pkg-config macros undefined
Added a check that PKG_PROG_PKG_CONFIG is defined before calling it so the user can see a proper error. Without it, the generated configure script will just pass on to the next statement and bomb with a strange shell syntax error.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4cd641b136..40c39b9912 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,12 @@ AC_PROG_CXX
AC_PATH_PROG(MAKE, make)
AC_PATH_PROG(MKDEP, makedepend)
AC_PATH_PROG(SED, sed)
+
+dnl Make sure the pkg-config macros are defined
+m4_ifdef([PKG_PROG_PKG_CONFIG],,[
+ AC_MSG_ERROR([The pkg-config autoconf macros are not defined.
+ Did you run 'make configure'?])]
+)
PKG_PROG_PKG_CONFIG()
dnl LIB_DIR - library basename