summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-15 20:04:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-20 22:34:29 +0200
commit0c44617e7f16f2e925fb2672d84bbc9dfccec0f8 (patch)
treebcfedc9c542593bbc4e8b61fca43e755b42cd98d
parent47a7c75bfbb304c1afa48f4d1dced372652c0c16 (diff)
lvm2: do not override CC and similar variables
Since lvm2 uses autoconf, there's no point in overriding CC and other variables at build time. This causes build breakage as CFLAGS aren't used at link time, therefore --sysroot lacks, which breaks the build with external toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/lvm2/lvm2.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/lvm2/lvm2.mk b/package/lvm2/lvm2.mk
index bc6f45872..2bd6b8bcf 100644
--- a/package/lvm2/lvm2.mk
+++ b/package/lvm2/lvm2.mk
@@ -74,7 +74,7 @@ $(LVM2_DIR)/.configured: $(LVM2_DIR)/.unpacked
$(LVM2_DIR)/.built: $(LVM2_DIR)/.configured
- $(MAKE1) CC=$(TARGET_CC) RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
+ $(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
$(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR) install
# Fixup write permissions so that the files can be overwritten
# several times in the $(TARGET_DIR)