summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2009-11-23 23:05:23 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 23:05:23 +0100
commit883f066797ae0e7a017fac8e275f6e58659db760 (patch)
treede10c1085278f7e08fe9dc84a38289ad164d59de
parent9627e21153693f296f41c0339e14d6ed18445d7e (diff)
SDL_image: fix runtime libjpeg failure
By default SDL_image loads libjpeg at runtime on-demand. The find_lib routine in the configure script of SDL_image searches the /usr/lib directory of the host machine to find the file name of the jpeg library. When the host on which Buildroot is being built contains newer version of libjpeg (e.g. libjpeg7), the configure script incorrectly uses its file name. The result is a runtime failure to load libjpeg. Fix this by disabling runtime load of libjpeg. [Peter: disable for png+tiff as well] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES2
-rw-r--r--package/sdl_image/sdl_image.mk3
2 files changed, 4 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 7580e5235..a390c22a7 100644
--- a/CHANGES
+++ b/CHANGES
@@ -28,7 +28,7 @@
libupnp, libuuid, libxml2, lighttpd, ltrace, lua, lzma, magiccube4d,
matchbox, mdadm, nbd, ncftp, ncurses, netkittelnet, netsnmp,
ng-spice-rework, ntfs-3g, openntp, openssl, pcmanfm, php, psmisc,
- python, quagga, radvd, rpm, rsync, rubix, samba, sawman, sdl,
+ python, quagga, radvd, rpm, rsync, rubix, samba, sawman, sdl, sdl_image,
shared-mime-info, sfdisk, spawn-fcgi, speech-tools, sqlite, squashfs,
synergy, syslinux, sysklogd, target-binutils, tcpdump, torsmo, u-boot,
udpcast, util-linux, valgrind, vsftpd, wipe, wpa-supplicant, x11vnc,
diff --git a/package/sdl_image/sdl_image.mk b/package/sdl_image/sdl_image.mk
index 127a2922b..772bb8606 100644
--- a/package/sdl_image/sdl_image.mk
+++ b/package/sdl_image/sdl_image.mk
@@ -14,6 +14,9 @@ SDL_IMAGE_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-sdltest \
--disable-static \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
--enable-bmp=$(if $(BR2_PACKAGE_SDL_IMAGE_BMP),yes,no) \
--enable-gif=$(if $(BR2_PACKAGE_SDL_IMAGE_GIF),yes,no) \
--enable-jpg=$(if $(BR2_PACKAGE_SDL_IMAGE_JPEG),yes,no) \