summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-02-28 23:35:48 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-29 10:00:24 +0100
commitdef11d79227d42976ae7c918f4a0ba44c94a0813 (patch)
tree18a134bdd69dab1ff6e6bf0fac74df096fbb04c6
parent6d24b41b097df67f73afc52babe8c454ebb30710 (diff)
libecore: fix build of host-libecore when X11 not available
The host-libecore build tries to build the X11 backend. This works if you have X11 headers/libraries installed on your build machine, but fails if you don't, and Buildroot shouldn't depend on such things being installed. Therefore, we force host-libecore to not build any of the graphical backends (X, XCB or DirectFB). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/efl/libecore/libecore.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/efl/libecore/libecore.mk b/package/efl/libecore/libecore.mk
index db14356ae..c76b3ffa2 100644
--- a/package/efl/libecore/libecore.mk
+++ b/package/efl/libecore/libecore.mk
@@ -12,7 +12,13 @@ LIBECORE_INSTALL_STAGING = YES
LIBECORE_DEPENDENCIES = host-pkg-config libeina
HOST_LIBECORE_DEPENDENCIES = host-pkg-config host-libeina host-libevas
-HOST_LIBECORE_CONF_OPT += --enable-ecore-evas
+HOST_LIBECORE_CONF_OPT += \
+ --enable-ecore-evas \
+ --disable-simple-x11 \
+ --disable-ecore-directfb \
+ --disable-ecore-x \
+ --disable-ecore-x-xcb \
+ --disable-ecore-imf-xim
# default options
LIBECORE_CONF_OPT = --disable-simple-x11