summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2012-06-21 19:38:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-23 23:18:39 +0200
commit07bae75635ebc0b2b3a2df8aca2f5022debacddb (patch)
treefdde8867c493f3692895c883505a26c83d790ed2 /Makefile
parent2a97045d5daeb7cb7222f1ffe0532930d5b3140d (diff)
source-check: change behavior to check only selected packages / add source-check-all
The original 'source-check' target first selects all packages, and then checks whether the package tarballs can be found. This is useful for Buildroot maintainers, but less useful for developers working on a specific project. The latter only care about the packages used in that project. This patch removes the allyesconfig dependency to source-check so that only selected packages are checked. The original behavior is moved to a new target 'source-check-all'. [Peter: removed source-check-all, people can just make allyesconfig before] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c69176731..7a66897cc 100644
--- a/Makefile
+++ b/Makefile
@@ -591,7 +591,7 @@ savedefconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
@$(COMMON_CONFIG_ENV) $< --savedefconfig=$(CONFIG_DIR)/defconfig $(CONFIG_CONFIG_IN)
# check if download URLs are outdated
-source-check: allyesconfig
+source-check:
$(MAKE) DL_MODE=SOURCE_CHECK $(EXTRAMAKEARGS) source
endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
@@ -678,7 +678,7 @@ endif
@echo
@echo 'Miscellaneous:'
@echo ' source - download all sources needed for offline-build'
- @echo ' source-check - check all packages for valid download URLs'
+ @echo ' source-check - check selected packages for valid download URLs'
@echo ' external-deps - list external packages used'
@echo
@echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build'