summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 16:45:21 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-19 16:09:30 +0200
commit4ef7ec585c904f3c68af391e220534981ded2bab (patch)
tree0b98775ee2052f1637e8480cca6e5728fbcc5052 /Makefile
parentc0e6b52482f244e5da6e8011d1737b0a21cef207 (diff)
Remove unused .fakeroot.* mechanism
There used to be a mechanism using which packages could leave a .fakeroot.<something> file which could contain commands to be executed within the fakeroot environment. Since this mechanism is no longer used by any package, remove it from the common infrastructure. The latest user was nfs-utils, which used this mechanism to do the "make install" as root, since doing otherwise was not supported. But since 16e7b8255c82815126a2c502c3787d442d254a86, nfs-utils has been upgraded and converted to the package infrastructure, and this hack is no longer necessary. Another past user was the ltp-testsuite package, for the same reason, and since a72a670489547a3ca645ff7c3a0d9c3fb66eab51, the fakeroot hack is no longer needed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index bb3a49bf9..845858044 100644
--- a/Makefile
+++ b/Makefile
@@ -302,8 +302,6 @@ endif
include fs/common.mk
-TARGETS+=erase-fakeroots
-
TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
@@ -392,7 +390,6 @@ $(BUILD_DIR)/.root:
if [ -d "$(TARGET_SKELETON)" ]; then \
cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
fi; \
- touch $(STAGING_DIR)/.fakeroot.00000; \
fi
-find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
-find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
@@ -400,9 +397,6 @@ $(BUILD_DIR)/.root:
$(TARGET_DIR): $(BUILD_DIR)/.root
-erase-fakeroots:
- rm -f $(BUILD_DIR)/.fakeroot*
-
target-finalize:
ifeq ($(BR2_HAVE_DEVFILES),y)
( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )