summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-05 21:53:13 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-16 15:06:45 +0100
commitcddfe67dd29c97f1964768159233bd76131f18af (patch)
treed31a4a897b1bf852d2e6fc13521fd959909833e2 /boot
parentca9d54b0ab1b975143ebd604e1308101ebc9cdb9 (diff)
u-boot: add CROSS_COMPILE/ARCH when building host tools
Even when building the host tools, for some reason U-Boot tries to execute the cross-compiler, so tell it which cross-compiler to use in order to avoid failure such as: /usr/bin/make -j12 -C /home/test/outputs/test-253-mini2440_defconfig/build/u-boot-custom tools make[1]: arm-linux-gcc: Command not found make[1]: Entering directory `/home/test/outputs/test-253-mini2440_defconfig/build/u-boot-custom' for dir in tools examples api_examples ; do /usr/bin/make -C $dir _depend ; done Generating include/autoconf.mk /bin/sh: line 3: arm-linux-gcc: command not found Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/u-boot/u-boot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 971920751..93825e125 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -144,7 +144,7 @@ $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
# uImage.
$(MKIMAGE): $(U_BOOT_DIR)/.patched
mkdir -p $(@D)
- $(MAKE) -C $(U_BOOT_DIR) tools
+ $(MAKE) -C $(U_BOOT_DIR) CROSS_COMPILE="$(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) tools
cp -dpf $(U_BOOT_DIR)/tools/mkimage $(@D)
# Build manually mkimage for the target