summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-10 21:59:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-10 21:59:54 +0200
commit7b819c32f8830676433764eb2fd7af6851bb5034 (patch)
tree1dec9bfa1363dfc8ee3a6fb08392c795fcecdb9a /package
parent5e0d46138fbba1197f4f9cef4b96c7b87f42a5a1 (diff)
uboot-mkimage: use correct host compiler/flags
As used elswwhere in BR. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch29
-rw-r--r--package/uboot-mkimage/uboot-mkimage.mk5
2 files changed, 32 insertions, 2 deletions
diff --git a/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch b/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch
new file mode 100644
index 000000000..0202eda9b
--- /dev/null
+++ b/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+
+ #########################################################################
+
+-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+- $(HOSTCPPFLAGS)
++HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP = strip
+
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+ # generates numerous errors and warnings. We want to bypass it
diff --git a/package/uboot-mkimage/uboot-mkimage.mk b/package/uboot-mkimage/uboot-mkimage.mk
index 055348c3c..b8f2ee5de 100644
--- a/package/uboot-mkimage/uboot-mkimage.mk
+++ b/package/uboot-mkimage/uboot-mkimage.mk
@@ -4,8 +4,9 @@ UBOOT_MKIMAGE_SITE = ftp://ftp.denx.de/pub/u-boot
define HOST_UBOOT_MKIMAGE_BUILD_CMDS
$(MAKE) -C $(@D) \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- ARCH=$(U_BOOT_ARCH) \
+ HOSTCC="$(HOSTCC)" \
+ HOSTCFLAGS="$(HOST_CFLAGS)" \
+ HOSTLDFLAGS="$(HOST_LDFLAGS)" \
tools
endef