summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2006-12-02 05:15:27 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2006-12-02 05:15:27 +0000
commitaadd9714b6eb183722a9209a3210457868bc2366 (patch)
treed6857d8e6edf0f07503749d272f968f7f3d228a5 /toolchain
parentb9d31ddac5ab51e7e8bcfc10b1f1e75ca581757f (diff)
For GCC 4.2 snapshots, we need to get the actual version from the BASE-VER file so that the target compiler will build and install properly.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 31c5d4b5f..00471d71e 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -335,9 +335,14 @@ endif
ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
-ifeq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
+ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
+ifneq ($(GCC_SNAP_DATE),)
+REAL_GCC_VERSION:=`cat ${GCC_DIR}/gcc/BASE-VER`
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
+else
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
+endif
$(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
PATH=$(TARGET_PATH) \