summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
-rw-r--r--target/Makefile.in3
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b14750d36..fb1716638 100644
--- a/Makefile
+++ b/Makefile
@@ -67,7 +67,6 @@ include .config.cmd
# in the .config file.
include toolchain/*/*.mk
include package/*/*.mk
-include target/*/*.mk
# target stuff is last so it can override anything else
include target/Makefile.in
diff --git a/target/Makefile.in b/target/Makefile.in
index ec3955a16..c4de07706 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,5 +1,8 @@
+# make sure to put everything that is board-specific before the tarroot targets
include target/generic/Makefile.in
include target/device/Makefile.in
include target/x86/Makefile.in
include target/arm/Makefile.in
include target/powerpc/Makefile.in
+# and finally build the filesystems/tarballs
+include target/*/*.mk