summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/Makefile.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index c89eb4227..908a45276 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -21,6 +21,13 @@ SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
else
SOFT_FLOAT_CONFIG_OPTION:=--without-float
endif
+# again... there must be a better way
+ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
+ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
TARGET_SOFT_FLOAT:=-msoft-float
ARCH_FPU_SUFFIX:=_nofpu
else