diff options
-rw-r--r-- | Makefile | 9 | ||||
-rw-r--r-- | make/customize.mk | 10 |
2 files changed, 19 insertions, 0 deletions
@@ -103,7 +103,16 @@ TARGETS+=busybox tinylogin # The Valgrind debugger (x86 only) #TARGETS+=valgrind +# Run customize.mk at the very end to add your own special config. +# This is useful for making your own distro within the buildroot +# process. +# TARGETS+=customize + +############################################################# +# # Pick your root filesystem type. +# +############################################################# TARGETS+=ext2root # Must mount cramfs with 'ramdisk_blocksize=4096' diff --git a/make/customize.mk b/make/customize.mk new file mode 100644 index 000000000..2cfed1834 --- /dev/null +++ b/make/customize.mk @@ -0,0 +1,10 @@ +############################################################# +# +# Any custom stuff you feel like doing.... +# +############################################################# +CUST_DIR:=$(SOURCE_DIR)/customize +ROOT_DIR:=$(BUILD_DIR)/root + +customize: + cp -af $(CUST_DIR)/* $(ROOT_DIR)/ |